Hi Janko:<br><br>
<div class="gmail_quote">On Mon, Jan 19, 2009 at 5:27 PM, Janko Mivšek <span dir="ltr">&lt;<a href="mailto:janko.mivsek@eranova.si">janko.mivsek@eranova.si</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">Hi Prashanth,<br>
<div class="Ih2E3d"><br>Prashanth Hebbar wrote:<br><br>&gt; Thanks a lot for pointing SpFilename. I haven&#39;t tried it but will try soon.<br>&gt;<br>&gt; I have another question more critical: when I add the line to register<br>
&gt; my url, it remains in &quot;red&quot; colour in the workspace which means there&#39;s<br>&gt; something wrong (right?) but the url opens without issue. However, I saw<br>&gt; that the sitename is not recognized in the addLinkTo: anObject text:<br>
&gt; aString view: #view.<br><br></div>So you registered an Url of your ANewsPortal and it now open in web<br>browser without a problem? If so, then everything is ok. Try to inspect<br>(AIDASite named: &#39;aidademo&#39;) urlResolver and its instvars #allWebPages<br>
and #allURLLinks to see, what you actually registered.<br>
<div class="Ih2E3d"></div></blockquote>
<div>&nbsp;</div>
<div>&nbsp;</div>
<div>Prashanth: inspect throws up a frighteningly huge list. &#39;Site&#39; shows an AidaSite</div>
<div><br>&gt; Here&#39;s a description of my &nbsp;app (modeled on the tutorial):<br>&gt; 1. I have model domains ANewsPortal (holds references to all news) and<br>&gt; ANews (defines news parts). I have ANewsPortalApp and ANewsApp.<br>
&gt;<br>&gt; 2. I have viewMain under ANewsPortalApp<br>&gt;<br>&gt; 3. I know i have to add a viewMain for ANewsApp and here is my<br>&gt; confusion: what view do I implement here.<br><br></div>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">Your model is almost a replica of that from Aida tutorial, so you should<br>made it working without a problem if you followed and understood the<br>
tutorial well. So, in ANewsApp implement the same view methods as they<br>are in ADemoAddressApp.<br>
<div class="Ih2E3d"></div></blockquote>
<div>&nbsp;</div>
<div>Prashanth: Yes it is. I am able to open <a href="http://localhost:8888/aidademo.html">http://localhost:8888/aidademo.html</a> and get my viewMain. However, trouble is when I am trying to link one of the items on the left nav bar with addLinkTo: site aidademo text: &#39;Mission&#39; view: #mission. Here&nbsp;&quot;aidademo&quot; is not recognized.</div>

<div>&nbsp;</div>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">
<div class="Ih2E3d"><span id=""></span><br>&gt; Sorry to bug you, I couldn&#39;t resolve this reading the tutorial.<br>&gt;<br>&gt; is this confusion contributing to the &quot;addLinkTo:&quot; issue I am facing?<br><br></div>
addLinkTo: aDomainObject will make an Url link automatically if not done<br>and registered in urlResolver before yet. So, for a link to a root<br>object (which you should register at the start) it will use already<br>registered one, while for all new objects (like new news in your case)<br>
Urls will be &nbsp;created and registered at the time you call addLinkTo: .<br>And as in tutorial, you can control the look of the generated Url by<br>#preferedUrl methon in your domain objects.<br>
<div class="Ih2E3d"></div></blockquote>
<div>&nbsp;</div>
<div>Prashanth: thanks for explaining these so patiently. This is what makes this list so warm.</div></div>-- <br>Prashanth Hebbar<br>Bangalore<br>