[aida] Stopping/Removing a Site

Rob Rothwell r.j.rothwell at gmail.com
Fri Jan 25 18:05:36 CET 2008


Thanks for all the help...please disregard the creation questions I have
been having.

I went back and reinstalled Aida 5.6 again and everything is working right.
My only guess is I had done a 5.4 "upgrade".

Thanks,

Rob

On Jan 24, 2008 6:42 PM, Rob Rothwell <r.j.rothwell at gmail.com> wrote:

> I have been working with a clean Aida 5.6 install on Squeak 3.9.
>
> I've been trying to start a new site (for example SwazooAida startOn:
> 8889) and have been getting the "Site with such host:ip:port combination not
> allowed!", so I figured I'd just remove the two existing Sites ("aidademo",
> and "swazoodemo") with:
>
> SwazooServer singleton removeSite: (SwazooServer singleton siteNamed:
> 'swazoodemo').
> SwazooServer singleton removeSite: (SwazooServer singleton siteNamed:
> 'aidademo').
>
>
> This worked great, but I had previously added an application to the
> "aidademo" site with
>
> (AIDASite named: 'aidademo') urlResolver defaultURL: '/myapp.html'
> forObject: myobj.
>
> and now even though I have removed the site, I can STILL browse to
> http://localhost:8888/myapp.html!
>
> Do I need to "stop" the application as well?  The sites do not show up in
> (SwazooServer singleton sites) anymore; how is it working if the server
> isn't listening?
>
> Sorry for such basic questions...I will create a "getting started with
> Aida" document when I have all these basics figured out!
>
> Thanks...
>
> Rob Rothwell
>
>
>


-- 
The foolish reject what they see, not what they think; the wise reject what
they think, not what they see.  -- Huang Po
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.aidaweb.si/pipermail/aida/attachments/20080125/c953bb56/attachment.htm 


More information about the Aida mailing list