[aida] AIDA and Squeak trunk

Herbert König herbertkoenig at gmx.net
Tue Jan 11 21:45:16 CET 2011


Hi,

JM> Try to follow Swazoo debugging instructions at
JM> http://www.swazoo.org/debbuging, maybe the error is somewhere in Swazoo

ok I did start. The only debugging success was to find a typo in:
"Here are steps to debug your Swazoo absed web projects:"
(letters exchanged in based so it reads absed)

I did Step one:
Add breakpoint to SwazooSite>>answerTo: (or your subclass of SwazooSite)

    * if breakpoint is reached, step forward to your code
    * if not reached, error is in Swazoo code, continue with next step

The breakpoint in AIDASite answerTo: was reached. I stepped through it
and never got into code which would produce the login page, so I guess
I should have stepped into at a place where I stepped over.

What happened was that after some stepping several debuggers came up
(I guess because the browser repeated the request because of a timeout
but they came up all at once). I closed these debuggers with continue
but the main debugger went into a circle ending up in the original
halt I put into answerTo:

So I guess I need more detailed instruction.
I tried with Aida6.1final2, sport2031 and swazoo2.2.mcz.

But remember it worked up to Trunk 10382 build and the first one I
noticed it stopped was a 10850 build. So it was a change in Squeak not
a bug in Swazoo.

I think the most effective steps would be to start from a 10382 trunk
(sadly I only have one with my app loaded and my modifications to
swazoo sport and aida) and update one update after the other and see
which update breaks Aida.
    
I you agree that these are the most effective steps I'll go to Squeak
dev and ask how to start from an older image and do one update at a
time.


Cheers,

Herbert                            mailto:herbertkoenig at gmx.net



More information about the Aida mailing list