[aida] 6.2 tests

Janko Mivšek janko.mivsek at eranova.si
Mon Feb 14 19:51:06 CET 2011


Hi Nicolas,

On 14. 02. 2011 19:39, Nicholas Moore wrote:

> From the demo.html page for ajax in 6.2, when I click on 'click me for
> popup' I have trapped a SwazooStream. It generates a requestURI which is
> '/aidasession/ajax'.
> 
> On the 6.1 version the equivalent requestURI is 'demo.html' (as I would
> expect).
> 
> Where does the '/aidasession/ajax URI come from?

This is major new behavior on new event framework - all Ajax and
WebSocket JSON messages go to this Url, that is, to your session, which
then find the right App and pass it the event. This Url is in JavaScript
code, see WebStyle js13Events. The Url of actual page is included in
this message.

Inspect the WebRouter (AIDASite default router) if there is a route to
the session manager. If you did the upgrade script, it should be there
already. If not, rerun that addSessionManagerRoute line.

In Firebug's console, do you see any error messages?

Hope this helps
JAnko

> 
> On Monday 14 Feb 2011 11:35:21 Nicholas Moore wrote:
> 
>> Janko,
> 
>>
> 
>> After running the script that you described prior to upgrade I was
> able to install 6.2 cleanly without any problems - good work!
> 
>>
> 
>> During testing (on VW) I came across a couple of snags:
> 
>>
> 
>> 1) The method String >> replaceSpecialCharacters contains or:or: which
> does not work in VW (but is ok in Pharo and Squeak). I changed it to:
> 
>> replaceSpecialCharacters
> 
>> |str|
> 
>> str := self copy.
> 
>> str do: [:ch | |ascii|
> 
>> ascii := ch asInteger.
> 
>> ((ascii >= 65 and: [ ascii <= 90 ]) or: [
> 
>> ( ascii >= 97 and: [ ascii <= 122 ]) or: [ch isDigit or: [ch = $/ or:
> [ch = $.]]]])
> 
>> ifFalse: [str replaceAll: ch with: $-]].
> 
>> ^str
> 
>>
> 
>> 2) I needed to upgrade my version of TinyMCE - richEditorInitScript
> has changed.
> 
>>
> 
>> 3) I have a problem with ajax calls. I previously used
> 'afterPostUpdate:' which is deprecated. I changed to
> 'onChangePostAndUpdate::' but that did not work (no error, simply
> nothing happened). I do not yet know why, I will need to do some
> debugging this week. I also found that the WebDemo ajax page did not
> work properly (the update and popup methods seemed to have no effect.
> 
>>
> 
>> Therefore I am unsure whether the problem lies in my implementation or
> elsewhere. I reverted to my same app using 6.1 and the WebDemo ajax page
> worked perfectly. If anyone else could test this and see how the demo
> app works, that would save me some time.
> 
>>
> 
>> By the way, I notice that WebApplication >> respondToAjaxRequest: is
> in the 'private-obsolete' protocol, should that be in 'private-ajax'?
> 
>>
> 
>> Otherwise the new features look great, in particular I am looking
> forward to getting to grips with JSON.
> 
>>
> 
>> Regards
> 
>>
> 
>> Nicholas
> 
>>
> 
>>
> 
> 
> -- 
> 
> Nicholas Moore
> 
> Skype: tsr_nicholas
> 
> Check out my Blog <http://nicholasmoore.eu/blog.html>
> 
> "Still Running - that I may die in good health"
> 
> 
> 
> _______________________________________________
> Aida mailing list
> Aida na aidaweb.si
> http://lists.aidaweb.si/mailman/listinfo/aida

-- 
Janko Mivšek
AIDA/Web
Smalltalk Web Application Server
http://www.aidaweb.si


More information about the Aida mailing list