[aida] STX troubles

Janko Mivšek janko.mivsek at eranova.si
Sun Jun 21 20:03:41 CEST 2009


Hi Jan,

Thanks for such fast answer! I tried also your branch but unfortunately
with the same result. BTW you branch is really nicely done, much cleaner
than official one.

Ok, let me not wast any more your and my time. I'll start working with
STX on Win for a while. So, how to load Swazoo and Aida on STX?

Here is the page with a Swazoo goodie:
http://smalltalk.felk.cvut.cz/projects/stx-goodies/wiki/StxGoodiesSwazoo

There is also the code to load it:

	Smalltalk loadPackage: 'stx:goodies/swazoo'

But it seems that this loads only the package which is on local file
system, not remote. So how to load such package remotely?

I tried to copy it locally and run above code, but ended with some
strange error.

Thanks and best regards
Janko


Jan Vrany pravi:
> Hi Janko, 
> 
> that's strange. You may try my branch
> (http://smalltalk.felk.cvut.cz/download/smalltalkx/smalltalk-5.4.6.20090620svn_linux.tar.bz2
> installation instructions:
> http://smalltalk.felk.cvut.cz/projects/stx-goodies/wiki/Download)
> - I put a most recent version there 10 mins ago. 
> 
> Let me know whether it works...
> 
>> What is wrong, should I rather recompile it for my Linux?
>>
> 
> No idea whats wrong. Both original eXept version and my 
> branch should work fine on any modern linux. 
> Moreover, recompilation of whole system is bit tricky,
> as you have no access to stc and librun (St/X VM) sources.
> 
> 
> Jan
> 
>> Best regards
>> Janko
>>
> 
> _______________________________________________
> Aida mailing list
> Aida na aidaweb.si
> http://lists.aidaweb.si/mailman/listinfo/aida
> 

-- 
Janko Mivšek
Svetovalec za informatiko
Eranova d.o.o.
Ljubljana, Slovenija
www.eranova.si
tel:  01 514 22 55
faks: 01 514 22 56
gsm: 031 674 565


More information about the Aida mailing list