[aida] Session Application State (was referencing my models...)
herbertkoenig at gmx.net
Sat Feb 7 17:25:05 CET 2009
JM> Well, a bit confusing. Maybe it is a time to rename them to more clear
JM> message? like #clearApplicationState ?
JM> Because in session's instvar #appsForObjects we have a dictionary with a
JM> matrix of all instances of Apps for all objects on that session, which
JM> is right to be called an application state, or session application
JM> state, as part of overall session state.
JM> What do you guys think?
yes that would have helped understanding and maybe even findig it
myself. But I confess that I personally (ab)use initialisation methods
for clearing the state of objects. At least when I do it I consider it
bad style, cause whenever I revisit that code later I ask myself why
that object hasn't been properly initialised earlier.
Herbert mailto:herbertkoenig at gmx.net
More information about the Aida