[aida] Session Application State (was referencing my models...)

Janko Mivšek janko.mivsek at eranova.si
Fri Feb 6 10:26:46 CET 2009

Herbert König pravi:

> JM>    self site sessionManager nilAppsForObjects

> nilAppsForObjects is nowadays initAppsForObjects?


Well, a bit confusing. Maybe it is a time to rename them to more clear
message? like #clearApplicationState ?

Because in session's instvar #appsForObjects we have a dictionary with a
matrix of all instances of Apps for all objects on that session, which
is right to be called an application state, or session application
state, as part of overall session state.

What do you guys think?


Janko Mivšek
Smalltalk Web Application Server

More information about the Aida mailing list