[aida] [Swazoo] Squeak issue ?

nicolas petton petton.nicolas at gmail.com
Tue Oct 23 16:54:18 CEST 2007


Hi, 

On VisualWorks, when Swazoo is running, if I save & quit the image and
restart it, Swazoo is still running. On Squeak, When I restart the
image, I've got a Socket process which uses 100% of CPU, and Swazoo is
not running anymore. It happens with Squeak 3.8, 3.9 and 3.10 beta.

If I stop swazoo, restart Squeak, and then start Swazoo there is no
problem. Did anyone notice this ? Should I consider reinstalling my VM ?

Well, I' not sure it's a Swazoo issue, it may be Squeak, Sport or
Aida... I didn't find where the problem is.

So, I had to add Swazoo to the SystemDictionary StartUpList and
ShutDownList:

SwazooServer class>>startUp
    self start

SwazooServer class>>shutDown
    self stop


Smalltalk addToStartUpList: SwazooServer.
Smalltalk addToShutDownList: SwazooServer

I know, it's a hack and it's uggly.

regards,

Nicolas

-- 
Nicolas Petton
http://nico.bioskop.fr
             ___
           ooooooo
          OOOOOOOOO
         |Smalltalk|
          OOOOOOOOO
           ooooooo
            \   /
             [|]
--------------------------------
Ma clé GPG est disponible ici :
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xE788C34D

-------------- section suivante --------------
Une pi�ce jointe non texte a �t� nettoy�e...
Nom: non disponible
Type: application/pgp-signature
Taille: 189 octets
Desc: Ceci est une partie de message
	=?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=
Url: http://lists.aidaweb.si/pipermail/aida/attachments/20071023/1fc35b46/attachment.sig 


More information about the Aida mailing list